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Introduction

Microsoft Access allows people to effectively and efficiently organize data. This document, 

Level 1, has been developed to introduce you to Microsoft Access. The various sections 

presented in this document will help you to build a solid knowledge foundation of the software. 

When you have mastered the objectives in this document, you can expand upon your 

knowledge of Microsoft Access by checking out the Level 2 and Level 3 documentation. 

Objectives

The following objectives are covered in this document: 

 Understanding how to create a table.

 Knowing the purpose of the primary key.

 Having the ability to implement error traps.

 Being able to enter descriptions for fields.

 Understanding how to add and delete fields.

 Having the ability to insert default fields into the form/table.

 Being able to create a drop-down list on the form.

 Having the ability to create a form.

 Understanding how to adjust the form properties.

 Being able to add and remove items on the form.

 Having the ability to adjust tabs on the form.

 Understanding how to input data into a form.

 Being able to work with the data in the database.

 Knowing how to attach photos to a record.

 Having the ability to create calculated fields.
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Creating the Database 

The following instructions explain how to create a database. 

1. Enter a file name in the File Name text box (see Figure 1).

 

2. Click the yellow folder to indicate where the file will be saved (see Figure 2).

Figure 1 – Creating a Database 

Figure 2 – Saving a File 
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3. The File New Database window will appear (see Figure 3). Select where to save the file 

and click the OK button. 

 

 
      

 

4. Click the Create button (see Figure 4). 

 

 
 

 

Figure 3 – Saving a Database 

Figure 4 – Create button 
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Creating a Table 

The following instructions explain how to create a table for an airline reservation system. 

 

1. Click the View button (see Figure 5). 

 

 
 

 

 

2. In the menu that appears, select Design View. 

3. Next, enter the name of the table (example: Reservations) that you are about to create 

in the Save As dialogue box (see Figure 6). 

 

 
 

 

4. Enter the Field Names and Data Types. Figure 7 shows an example of a table that could 

be used for an airline reservation system.  

 

 
 

 

 

Figure 5 – View button 

Figure 6 – Table Name 

Figure 7 – Example of Table for an Airline Reservation System 
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The following explains the different data types that could be used for the table: 

 

a. AutoNumber – The database will create a unique number for each record that is 

entered. 

b. Text – Use for fields that contain letters and numbers. This option can contain up 

to 255 characters. 

c. Memo – Use for fields requiring long entries. Both letters and numbers can be 

created in this field. This option can hold up to 65,536 characters. 

d. Number – Define the field as this choice when numbers will be required for the 

field. 

e. Date/Time – Select this choice when you need to enter a date or time. 

f. Currency – This option is chosen when dollars and cents need to be entered into 

the field. 

g. Yes/No – This appears as a check-mark box. Use this choice when the field 

requires a yes or no entry. 

h. OLE Object – When this is selected, the field can contain a picture or sound clip.  

i. Hyperlink – Good choice when email addresses and hyperlinks are required. 

j. Attachment – This option allows the user to attach one or more pictures to the 

record.  

k. Lookup – This option helps the user create a drop-down list for the field. When 

this option is selected, the Lookup Wizard will begin. 

Things to Remember When Creating a Table 

It is important to remember the following when creating a table. 

Primary Key 

Records in Access can be organized by a unique, identifying number. The primary key is used to 

ensure that no two records have the same number. For example, in the table created for an 

airline reservation system (see Figure 8), it is important that each passenger has a unique 

Transaction Number.   

 

 
 

 
Figure 8 – Example of Table for an Airline Reservation System 
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The primary key can be used for the following data types: Auto Number, Number, and Text. 

 

The primary key can be toggled on and off by clicking on the Primary Key button located on the 

Design tab (see Figure 9). 

 

 
 

 

 

When the Primary Key is active, it will appear as a key icon to the left of the field name (see 

Figure 10). 

 

 
 

 

Error Traps 

Error traps help to make certain that correct data is entered into the database by users. For 

example, for the field Destination City in Figure 11, perhaps the only three cities that should be 

entered are Atlanta, Chicago, and Miami.  

 

 
 

Figure 9 – Primary Key 

Figure 10 – Key Icon 

Figure 11 – Airline Reservation Table 
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The following explains how to create an error trap for this field. 

 

1. Click to select the field Destination City (see Figure 12). 

 

 
 

 

 

2. Click Validation Rule (see Figure 13).   

 

Figure 12 – Airline Reservation Table 

Figure 13 – Validation Rule 
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To make certain that the user enters only Atlanta, Chicago, or Miami, enter the following: 

Atlanta or Chicago or Miami 

 

If you were working with numbers, you could also enter a formula to make certain that only 

a specific range of numbers are entered. For example, if you wanted to make sure that only 

numbers from 0 to 100 are entered, you would enter the following: >= 0 and <= 100 

 

3. Next, select Validation Text (see Figure 14). 

 

 
 

 

 

4. Whatever appears in Validation Text is the message that will appear if a user attempts 

to enter data that violates the Validation Rule that was entered in Step 2. For example, 

the following is an example of a message that could be entered: Invalid Entry! Please 

enter one of the following cities: Atlanta, Chicago, or Miami 

 

 

Figure 14 – Validation Text 
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Figure 15 is an example of how the error message would appear to the user. 

 

 
 

 

Descriptions 

The description area (see Figure 16) is a place where you can provide instructions to the users. 

The users will see the instructions as they enter the various fields for the database.  

 

 
 

 

The following explains how to create a Description for a field. 

 

1. Place your cursor in the Description column next to the field of your choice (see Figure 16). 

2. Enter a meaningful description for the user. For example, for the Meal field in Figure 17, 

you could eŶter, ͞Please seleĐt if the Đustoŵer ǁaŶts a ŵeal oŶ the flight.͟ 

 

 
 

 

 

Figure 15 – Error Message 

 

Figure 16 – Description 

 

Figure 17 – Description 
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Figure 18 shows where the Description text will appear when the user selects the Meal field. 

 

 
 

 

Adding and Deleting Fields 

Once the table has been completed for the database, it is possible to add and delete fields. The 

following explains how to add the field Transaction Date to Figure 19 between Transaction 

Number and First Name. 

 

 
 

 

 

Figure 18 – Description 

 

Figure 19 – Adding and Deleting Fields 

 

Add Transaction Date 
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1. Allow your mouse pointer to hover over the field First Name (see Figure 20) and right-click. 

 

 
 

 

2. In the menu that appears, select Insert Rows (if you want to delete this field, you would 

select Delete Rows). Upon completing this step, a row will be available for you to enter the 

field Transaction Date (see Figure 21). 

 

 
 

 

Default Values 

As the database designer, you have the option of including Default Values. For example, in the 

table in Figure 22, suppose that 99% of the entries for Departure City will be Atlanta. You could 

include a default value of Atlanta to make the data entry easier for the user.  

 

 
 

Figure 20 – Adding and Deleting Fields 

 

Figure 21 – Adding and Deleting Fields 

 

Figure 22 – Default Values 
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The following explains how to include the default value of Atlanta for Departure City. 

 

1. Select the field Departure City (see Figure 23). 

 

 
 

 

2. Click Default Value (see Figure 24). 

 

 
 

 

Figure 23 – Default Values 

 

Figure 24 – Default Values 
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3. Enter Atlanta (see Figure 25). 

 

 
 

 

4. When the user opens a form, Atlanta will appear as a default for the field Departure City 

(see Figure 26). This will make the job of the data entry person easier because he or she will 

not need to type Atlanta.  

 

However, another city can be entered for Departure City, if desired. For example, Chicago 

could be entered in place of Atlanta. 

 

   

 

 

 

Figure 25 – Default Values 

 

Figure 26 – Default Values 

 

Atlanta – Default Value 
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Creating a Drop-Down List 

A drop-down list can make the job of the data entry person easier. When a drop-down list is 

available, the user simply clicks the list and selects the option of his or her choice.  

 

For example, in Figure 27, Destination City would be the perfect place to include a drop down 

list. If the cities for the Destination City field were Atlanta, Chicago, and Miami, the user would 

simply click the list and select the city of his or her choice. This eliminates a lot of typing for the 

user. 

 

 
 

 

The following steps explain how to create a drop-down list for the field Destination City. 

 

1. For Destination City, select the down-arrow (see Figure 28). 

 

 
 

 

 

 

 

 

 

Figure 27 – Creating a Drop-Down List 

 

Figure 28 – Down-Arrow 
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2. From the menu that appears, select Lookup Wizard (see Figure 29). 

 

 
 

 

 

3. The Lookup Wizard dialogue ďoǆ ǁill appear. “eleĐt the optioŶ, ͞I ǁill tǇpe iŶ the ǀalues 
that I ǁaŶt.͟ TheŶ, ĐliĐk the Next button (see Figure 30). 

 

 
 

 

 

 

 

Figure 29 – Lookup Wizard 

 

Figure 30 – Lookup Wizard 
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4. Under Col 1 (see Figure 31), type the values that you want to appear. Then, click the 

Finish button. 

 

 
 

 

 

5. Figure 32 shows how the drop-down list would appear in the form for the user. 

 

 
 

 

 

 

Figure 31 – Lookup Wizard 

 

Figure 32 – Drop-down List 
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Opening and Closing the Table 

 

WheŶ Ǉou are fiŶished ĐreatiŶg the taďle, it ĐaŶ ďe Đlosed ďǇ ĐliĐkiŶg the ͞X͟ iŶ the upper-right 

area of the table (see Figure 33). 

 

 
 

 

 

To open the table again, double-click the name of the table that you want to open. The name of 

the table will appear on the left area of the window (see Figure 34). 

 

 
 

Figure 33 – Closing the Table 

 

Figure 34 – Opening the Table 
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Forms 

The following explains how to create and design forms in Access. 

Create the Form 

 

The following instructions explain how to create an interactive form that allows the user to 

effectively interact with the database. 

 

1. From the Create tab, click Form Design (see Figure 35). 

. 

 
 

 

2. A blank form will appear on your screen (see Figure 36).  

 

 
 

Figure 35 – Form Design 

 

Figure 36 – Access Form  
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Form Properties 

 

You create the form by using the Property Sheet. To see the Property Sheet, click the Property 

Sheet button on the Design tab (see Figure 37). 

 

 
 

 

The Property Sheet will appear on the screen (see Figure 38) and provide you with many 

options allowing you to develop an effective form. 

 

 
 

Figure 37 – Property Sheet  

 

Figure 38 – Property Sheet  
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Changing the Color of a Form 

The following explains how to change the color of a form. 

 

1. Click the Form with your mouse so that it is the active object in Access (see Figure 39). 

 

 
 

 

 

2. In the Property Sheet, click the Format tab (see Figure 40). 

 

 
 

Figure 40 – Property Sheet  

 

Figure 39 – Form  

 

Click the form with 

your mouse so that it 

is the active object. 
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3. Click to select the right-column for Back Color on the Property Sheet (see Figure 41). 

 

 
 

 

4. In the Property Sheet, for Back Color, click the  button (see Figure 42). 

 

 
 

 

5. A window containing many colors will appear on your screen. Select the color that you 

want to apply to your form. 

 

 

  

Figure 41 – Back Color  

 

Click the 

right column 

for Back 

Color. 

Figure 42 – Back Color  
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Drawing Labels 

 

Labels allow you to create items such as banners on your form. The following explains how to 

add a banner to a form. 

 

1. On the Design tab, click the Label button (see Figure 43). 

 

 
 

 

 

2. Draw a text box on the form (see Figure 44). 

 

 
 

 

 

 

 

Figure 43 – Label Button  

 

Figure 44 – Text Box  

 

Text Box 
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3. Type your text in the text box. 

4. Select the text. 

5. The text can be formatted from the Text Formatting area of the Home tab (see Figure 

45). 

 

 
 

 

 

6. Click the form to deselect the text box.  

7. Then, click the text box again to select it. When you allow your mouse pointer to hover 

over the edge of the text box (see Figure 46), you can hold your mouse button down 

and move the text box to the location of your choice on the form.  

 

 
 

 

 

 

 

 

Figure 45 – Text Formatting 

 

Allow your mouse pointer to hover 

over the edge of the text box. 

Figure 46 – Moving the Text Box 
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8. You can re-size the text box by allowing your mouse pointer to hover over an anchor 

point (see Figure 47), holding down your mouse button, and moving the mouse. 

 

 
 

 

Drawing Lines 

 

Lines can be used as an organizational tool for the form. For example, lines can create different 

areas on the form. The following explains how to draw a line on the form. 

 

1. Click the Line button (see Figure 48) from the Design tab. 

 

 
 

 

2. Allow your mouse pointer to hover over the form, hold down the mouse button, and 

move your mouse. This action will draw a line on the form. 

 

Figure 47 – Re-sizing the Text Box 

 

Figure 48 – Line tool 

 

Allow your mouse pointer to hover 

over an anchor point (there are 

eight anchor points on this form). 
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3. Click to select the line. 

4. In the Property Sheet, on the Format tab, you can adjust the width and color of the line 

(see Figure 49). 

 

 
 

 

Adding Fields to the Form 

 

The following explains how to add fields to the form. 

 

1. If the Property Sheet is opeŶ, ĐliĐk the ͞X͟ iŶ the upper-right area of the Property Sheet 

to close this window (see Figure 50). 

 

 

Figure 49 – Adjusting the width and color of a line 

 

Figure 50 – Closing the Property Sheet 
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2. From the Design tab, click the Add Existing Fields button (see Figure 51). 

 

 
 

 

3. The Field List window will appear. Click Show all tables (see Figure 52). 

 

 
 

 

4. CliĐk the ͞+͟ Ŷeǆt to the Ŷaŵe of Ǉour taďle that ĐoŶtaiŶs the fields that Ǉou ǁaŶt to add 
to your form (see Figure 53). 

 

 
 

Figure 51 – Add Exiting Fields 

 

Figure 52 – Show all tables 

 

Figure 53 – Adding Fields 
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5. Move the fields from the Field List window to the Form (see Figure 54) by following the 

instructions below. 

a. Allow your mouse pointer to hover over the name of the field in the Field List 

window that you want to place on the form. 

b. Press and hold down your mouse button. With the mouse button pressed down, 

move the field to the form.  

c. When the field is over the form, release your mouse button and the field will be 

added to the form. 

 

 
 

 

Arranging Fields on the Form 

 

The following instructions explain how to quickly arrange the fields on the form. 

 

1. Select all of the fields that you want to arrange on the form. To select all of the fields, 

follow the instructions below. 

a. On the form, allow your mouse pointer to hover over the upper-left area where 

your fields are located. 

b. Press and hold down your mouse button. 

c. As you move your mouse button towards the fields, you can draw a selection 

box to select all of the fields. 

d. When you release the mouse button, all of the fields that were contained in the 

selection box will be selected. 

 

 

 

 

Figure 54 – Adding Fields 

 

Field List 

Form 
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2. From the Arrange tab, click Stacked (see Figure 55).

 

3. Click the Remove Layout button (see Figure 56).

 

4. The fields will be neatly arranged on the form (see Figure 57).

 

Figure 55 – Stacked Button 

Figure 56 – Remove Layout Button 

Figure 57 – Fields on the Form 
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Removing a Tab Stop for a Field 

 

The following explains how to remove a tab stop for a field. As an example, in Figure 58, 

Transaction Number is defined as an auto-number. Therefore, no input is required from the 

user. For this reason, the tab stop for this field will be removed. 

 

 
 

 

1. From the Design tab, click Property Sheet (see Figure 59). 

 

 
 

 

 

Figure 58 – Fields on the Form 

 

Figure 59 – Property Sheet 
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2. Click to select the text box for Transaction Number (see Figure 60). 

 

 
 

 

3. In the Property Sheet, click the Other tab (see Figure 61). 

4. In the Property Sheet, for Tab Stop, click to change Yes to No (see Figure 61). 

 

 
 

 

 

 

 

 

Figure 60 – Select the Text Box 

 

Select 

the text 

box 

Figure 61 – Property Sheet 

 

Click to 

change 

to No 
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Changing the Tab Order 

 

The following explains how change the tab order for a form. 

 

1. From the Design tab, click Tab Order (see Figure 62). 

 

 
 

 

2. The Tab Order dialogue box will appear (see Figure 63). 

3. Click to the Left of the field name to select the field where you want to adjust the order 

(see Figure 63). 

4. After the field name is selected, click to the left of the field name and hold down your 

mouse button. As your mouse button is pressed down, move the field to re-arrange the 

tab order in the window. 

5. When you have re-arranged the tab order, click the OK button to close the window. 

 

 
 

 

 

 

 

Figure 62 – Tab Order 

 

Figure 63 – Tab Order 

 

Always click the area to 

the left of the field names 

to select and re-arrange 

the order. 
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Entering Data in the Form 

 

The following explains how to enter data in the form. 

 

1. From the Design tab, click View (see Figure 64). 

 

 
 

 

2. From the menu that appears, select Form View. 

3. You can now enter data into the various text boxes on the form.  

a. Press the tab key to go to the next field. 

b. Press shift + tab to go to the previous field.  

4. When you have entered data into all of the fields on the form, press the tab key and you 

will go to the next record where you can enter more data. 

5. The following instructions explain how to return to the Design view so that you can 

make adjustments to the layout and design of the form. 

a. From the Home tab, click the View button (see Figure 65). 

b. From the menu that appears, select Design View. 

  

 
 

 

Saving the Form 

 

The following explains how to save the form. 

 

1. Click the File tab (see Figure 66).  

 

 

Figure 64 – View Button 

 

Figure 65 – View Button 

 

Figure 66 – File tab 
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2. From the menu that appears, click Save (see Figure 67). 

 

 

3. In the next window that appears, enter a filename and click the OK button. It may help 

you stay organized if you name the form the same name as the table that the form is 

associated with. 

4. To Đlose the forŵ, ĐliĐk the ͞X͟ iŶ the upper-right area of the form (see Figure 68). 

 

 

Figure 67 – Save Button 

 

Figure 68 – Closing the Form 
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5. To open the form again, double-click the form name (see Figure 69). 

 

 
 

 

6. The following instructions explain how to return to the Design view so that you can 

make adjustments to the layout and design of the form. 

a. From the Home tab, click the View button (see Figure 70). 

b. From the menu that appears, select Design View. 

 

 

 

Figure 69 – Opening the Form 

 

Double-click the name of 

the form to open it. 

Figure 70 – View Button 
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Moving Between Records on the Form 

 

To move between records on the form, use the controls at the bottom-left of the window (see 

Figure 71). 

 

 
 

 

 

Figure 72 explains the purpose of each navigational button.  

 

 
 

 

 

 

 

 

 

 

 

 

Figure 71 – Navigational Buttons 

 

Figure 72 – Navigational Buttons 

 

Move to the first record. 

Move to the previous record. Move to the next record. 

Move to the last record. 

Create a new record. 
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Searching for a Record 

 

The following explains how to search for a record in Access. 

 

1. Place the cursor in the field where you are searching for a match. For example, in Figure 

73, if you were searching for a person’s last Ŷaŵe, Ǉou ǁould plaĐe the Đursor iŶ the 
text box for last name. 

 

 
 

 

2. Next, on the Home tab, click the Find button (see Figure 74). 

 

 
 

 

 

 

 

Figure 73 – Record Searches 

 

Figure 74 – Find Button 
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3. In the window that appears, enter item that you are searching for (last name) and click 

the Find Next button (see Figure 75). 

 

 
 

 

4. The item that you are searching for will appear on the form. Click the Find Next button 

to go to the next match; when there are no more matches, a message will appear 

indicating the search item was not found. 

 

Applying a Filter with Access 

 

The following explains how to apply a filter in Access. 

 

1. Place your cursor in the field that you want to filter. For example, in Figure 76, if you 

wanted to only see flights destined for Chicago, you would place your cursor in the 

Destination City field. 

 

 
 

Figure 75 – Search Window 

 

Figure 76 – Filtering Records 
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2. From the Home tab, click the Filter button (see Figure 77). 

 

 
 

 

3. In the menu that appears, remove all of the check-marks except for the one for Chicago 

(see Figure 78) and the click the OK button. 

 

 
 

 

4. As you navigate through the records, you will only see the records destined for Chicago. 

5. To remove the filter so that you can see the other records again, click the Filtered 

button (see Figure 79) at the bottom-left area of the window. 

 

  

Figure 77 – Filter Button 

 

Figure 78 – Filter  

 

Figure 79 – Remove Filter Button  
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Attaching Photos to a Record 

 

In many situations, it is helpful to attach a photo to a record. The following explains how to 

attach a photo to a record. 

 

1. When you create the Photo record in the table, allow the data type to be defined as an 

Attachment (see Figure 80). 

 

 
 

 

2. Place the photo field on the form. Make certain the area that will contain the photo is 

large enough to see the image (see Figure 81). 

 

 

Figure 80 – Attachments  

 

Figure 81 – Photos  
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3. Once the form is complete and you are entering the data for the record, do the 

following to attach the photo to the record: 

a. Double-click inside of the box for the photo field (see Figure 82). 

b. The Attachments window will appear on the screen. Click the Add button. 

c. Browse for the photo on your computer. When you select the photo, click the 

Open button. 

d. You will now return to the Attachments window. Click the OK button. 

 

 
 

 

Creating Calculated Fields 

 

When performing calculations in Access, the calculations are created on the form. The following 

explains how a Total field could be created for Figure 83 that would display the total sales for 

Store 1 and Store 2. 

 

 
 

Figure 82 – Attaching Photos to Records 

 

Double-click 

inside the box 

to display the 

Attachments 

window. 

Figure 83 – Calculated Fields 
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1. Insert a text box onto the form by clicking the Text Box button (see Figure 84). 

 

 
 

 

2. Draw the text box on the form (see Figure 85). 

 

 
 

 

3. Click to select the label (see Figure 86). Then, enter descriptive text for the field. Also, 

format the text box to match the other text boxes on the form. 

 

 
 

 

Figure 84 – Text Box Button 

 

Figure 85 – Text Box 

 

Figure 86 – Labels 
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4. From the Design tab, click the Property Sheet button (see Figure 87). 

 

 
 

 

5. Click to select the text box (see Figure 88) that you added in Step 2. 

 

 
 

 

6. In the Property Sheet, click the Other tab. For Name, give a meaningful name to the 

selected text box. For this example, Total Sales was entered (see Figure 89). 

 

 
 

 

Figure 87 – Property Sheet Button 

 

Figure 88 – Property Sheet Button 

 

Figure 89 – Name 
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7. In the Property Sheet, click the Data tab. For Control Source, click the  button (see 

Figure 90). 

 

 
 

 

 

8. The Expression Builder will appear. Enter the formula into the Expression Builder. The 

following will help you to build formulas: 

a. Always begin a formula with the following: = 

b. You will find your fields that are used on the form listed in the Expression 

Categories area (see Figure 91). Double-click these fields to add them to the 

Expression Builder. 

c. Click the OK button when you are done building the formula. 

 

 

Figure 90 – Control Source 

 

Figure 91 – Expression Builder 
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9. Click the Format tab (see Figure 92). Select the format of your choice.

 

10. As you enter data into the form, the total will be displayed (see Figure 93).

Figure 92 – Format Tab 

Figure 93 - Total


