
Advanced PowerPoint 2010 

 
You can animate the text, pictures, shapes, tables, SmartArt graphics, and other objects in your 

Microsoft PowerPoint 2010 presentation to give them visual effects, including entrances, exits, changes 

in size or color, and even movement.  

Overview of animating text and objects 

Animation is a great way to focus on important points, to control the flow of information, and to 

increase viewer interest in your presentation. You can apply animation effects to text or objects on 

individual slides, to text and objects on the slide master (slide master: The main slide that stores 

information about the theme and layouts of a presentation, including the background, color, fonts, 

effects, placeholder sizes, and positions.), or to placeholders on custom slide layouts. 

There are four different kinds of animation effects in PowerPoint 2010: 

 Entrance effects. For example, you can make an object fade gradually into focus, fly onto the 

slide from an edge, or bounce into view. 

 Exit effects. These effects include making an object fly off of the slide, disappear from view, or 

spiral off of the slide. 

 Emphasis effects. Examples of these effects include making an object shrink or grow in size, 

change color, or spin on its center. 

 Motion Paths (motion path: The path that a specified object or text will follow as part of an 

animation sequence for a slide.). You can use these effects to make an object move up or down, 

left or right, or in a star or circular pattern (among other effects). 

You can use any animation by itself or combine multiple effects together. For instance, you can make a 

line of text fly in from the left while it grows in size by applying a Fly In entrance effect and a 

Grow/Shrink emphasis effect to it.  

 

Add animation to an object  

 
1. To add an animation effect to an object, do the following: 

2. Select the object that you want to animate. 

3. On the Animations tab, in the Animation group, click the More button, and then select the 

animation effect that you want. 



 

 NOTES  

 If you do not see the entrance, exit, emphasis, or motion path animation affect that you want, click 

More Entrance Effects, More Emphasis Effects, More Exit Effects, or More Motion Paths. 

 After you have applied an animation to an object or text, the animated items are labeled on the slide 

with a non-printing numbered tag, displayed near the text or object. The tag appears only in Normal 

view when the Animations tab is selected or the Animation task pane is visible 

Apply multiple animation effects to a single object 

To apply multiple animations onto the same object, do the following:  

1. Select the text or object that you want to add multiple animations. 

2. On the Animations tab, in the Advanced Animation group, click Add Animation. 

 

View a list of animations currently on the slide 

You can view the list of all the animations on the slide in the Animation task pane. The Animation task 

pane shows important information about an animation effect, such as the type of effect, the order of 

multiple effects in relation to one another, the name of the object affected, and the duration of the 

effect. 

To open the Animation task pane, on the Animations tab, in the Advanced Animation group, click 

Animation Pane. 
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4.  In the task pane, numbers indicate the order in which the animation effects play. The numbers 

in the task pane correspond to the non-printing numbered tags that are displayed on the slide. 

5.  Timelines represent the duration of the effects. 

6.  Icons represent the type of animation effect. In this example, it is an Exit effect. 

7.  Select an item in the list to see the menu icon (down arrow), and then click the icon to reveal 

the menu. 

 

Set the effect options, timing, or order for an 

animation 

 To set the effect options for an animation, on the Animations tab, in the Animation group, click the 

arrow to the right of Effect Options and click the option that you want. 

 You can specify the start, duration, or delay timing for an animation on the Animations tab.  

 To set the start timing for an animation, in the Timing group, click the arrow to the right of the 

Start menu and select the timing that you want. 

 To set the duration of how long the animation will run, in the Timing group, enter the number 

of seconds that you want in the Duration box. 

 To set a delay before the animation begins, in the Timing group, enter the number of seconds 

that you want in the Delay box. 

 To reorder an animation in the list, in the Animation task pane, select the animation that you want to 

reorder, and on the Animations tab, in the Timing group, under Reorder Animation, either select Move 



Earlier to make the animation occur before another animation in the list or select Move Later to make 

the animation occur after another animation in the list. 

 

Test your animation effect 

After you add one or more animation effects, to validate that they work, do the following: 

 On the Animations tab, in the Preview group, click Preview. 

 

 

Five tips for creating animations in PowerPoint 2010 

Takeaǁay: If you’ǀe struggled iŶ the past ǁith PoǁerPoiŶt’s aŶiŵatioŶ tools, you ŵay fiŶd the situatioŶ has 
improved with the latest version. Here are a few easy ways to create animation effects with PowerPoint 

2010. 

In previous versions of PowerPoint, animating elements on the screen was in equal parts (to me, at least) 

amusing and annoying. I loved it when the items did their little swirls or faded into view at just the right 

time. But I fussed and fumed over that one word bubble that would never arrive on cue. Now in PowerPoint 

2010, the animation feature is easier — and goes farther — ǁith just a feǁ clicks of the ŵouse. Here’s a 
small taste of these improvements. 

1: Use ready-made animations 

The Add Animation gallery presents simple animations you can easily apply to items on your 

slide. Simply click the element you want to animate, click the Animation tab, and click Add 

Animation. The gallery (Figure A) shows a number of simple animations that control the way 

objects enter, exit, appear, and disappear on your slides.  

 

 

 

 



Figure A 

 

The Add Animation gallery offers assorted ready-made animations you can apply to elements on your slide. 

2: Set triggers 

A trigger enables you to tie your animation to another action on the slide. You can create 

bookmarks in your presentation that trigger an animation to begin, or you can set the 

animation to start when you click the mouse. You can further control the trigger by indicating 

which action you will take to trigger the animation. Set a trigger for an animation by clicking the 

animated item and then clicking Trigger in the Advanced Animation group of the Animations 

tab.  

 



3: Use the Animation Painter 

It’s Ŷot uŶheard of to spend hours trying to get everything in your presentation animated 

perfectly. Getting things to move at the right speed, in the right order, and ending in the right 

sequence used to be a pretty tricky business. Now you can automate the animation sequences 

you like by using the Animation Painter. Available in the Advanced Animation group, the 

Animation Painter works like the Format Painter tool. You click the element with the animation 

you want to copy, click Animation Painter, and then drag the pointer over the item you want to 

receive the animation settings. PowerPoint does the rest.  

4: Let the timeline help you out 

The timeline appears at the bottom of the Animation Pane to help you see how the animations 

are unfolding on your slide. You can use the timeline to gauge the entry and exit of various 

items and to determine whether you want to change the time or sequence of events. Each 

individual animation also shows the length of time it requires by displaying a small time 

segment to the right of each animation entry. You can scroll along the timeline by clicking the 

arrows at either end or click the Seconds control to Zoom In or Zoom Out and change the 

increments of time you are working with (Figure B). This can help you fine-tune the animations 

so that the motion occurs precisely when you want it to.  

Figure B 

 

You can change the increments on the timeline to fine-tune the animation of elements on your slide. 

5: See it all in the Animation Pane 

The Animation Pane (Figure C) brings together all kinds of information and tools for you to use 

as you organize, order, and time the animation features you add to elements on your slides. 

Display the Animation Pane by clicking the Animation tab and choosing Animation Pane in the 

Advanced Animation group. The task pane lets you preview the animation (click Play), reorder 

animations, and see where they fall on the timeline. You can also access options related to each 

animation by clicking its arrow and choosing the tool you want to use. You can set options, 

control time, or even remove the animation if you like.  

 

 



Figure C 

 

The Animation Pane brings together all the settings you may want to change for individual animations. 

 

 

 

 

 

 

 

 

 



Advanced Animation Timeline 

When you need to fine tune the animation timings, you need to display the very powerful 
Advanced Timeline. When you open the animation pane, which do you see: 
 

 
 

With the advanced Timeline you can see the duration, start and end for each animation in 
relation to the other animations. For advanced animation needs the WITH PREVIOUS setting is 
utilized more and the animation start position and duration are adjusted with the Advanced 
Timeline (as example when a subtle overlapping animation is needed). 
 

 
To see the Advanced Timeline, click any animation and choose SHOW ADVANCED TIMELINE. 

 



Recording a Voice Narration in PowerPoint 

You might want to add narration to a presentation in the following cases: 

 For a Web-based presentation 
 For archiving a meeting so that presenters can review it later and hear comments made 

during the presentation 
 For self-running slide show presentations 

Your computer must be equipped with a sound card, microphone, and speakers for you to 
record and hear a narration. You can record the narration before you run a presentation, or 
record it during the presentation and include audience comments in the recording. 

If you don't want narration throughout the presentation, you can record comments on selected 

slides. When you're finished recording a narration, a sound icon appears on each slide where 
you've recorded. You can either click the icon to play the sound, or set up the sound to play 
automatically. 

Because voice narration takes precedence over other sounds, if you've inserted another sound 
to play automatically in the presentation, it gets overridden by the narration. 

Automatic slide timings 

As you record, Microsoft PowerPoint records the amount of time you take on each slide. You 
can choose to save these slide timings with the narration, or you can set slide timings 
separately. Slide timings are especially useful if you want the presentation to run through 
automatically. You can turn them off when you don't want the presentation to use them. 

Embed or link the narration 

You have a choice to either link or embed the narration. 

 If you embed the narration, the narration sound file becomes part of the presentation and 
it travels with the presentation. However, embedding the narration results in a large file 
size.  

 If you want the file size to be smaller, you can link the narration. The file is then stored 
where you specify on your hard drive and plays with the presentation. If you present the 
show on a different computer, you must carry the linked sound file with you and install it 
on that computer. A linked file will also play faster. 

Accompany the narration with notes 

Because audience needs and computer equipment varies, consider accompanying your 
narration with notes. This benefits anyone who is deaf or hard of hearing or whose computer 
lacks a sound card. If you save the presentation as a Web page (.htm file), the notes will appear 
beneath each slide as it displays. If you save it as a presentation (.ppt) file, you can print out the 
notes and make them available to your audience. 



Instructions 

1. Prepare the PPTX slides with all the animation effects that you want to include; 
 

2. Prepare notes for each slide with your narration; 
 

3. Take a printout of your notes and mark the places in the text where you want to 
click for the animation effects to start during the slide show presentation; 
 

4. Make mp3 files with your narration for each slide using the notes.  
 

5. From the "Insert" panel, insert audio files in the slides 
 

6. Open the "Animation Pane" in the "Animations" panel 
 
a. Move the audio file to the top of the list of effects. Make sure that the 
animation effect for the audio file is set to "Play."  
b. From the top-down menu for the audio file in the Animation Pane, click "Start 
With Previous." The audio file order number should show "0." 
c. Select from the top-down menu "Effect Options" and change "Stop playing" to 
"After current slide." 
 

7. Click "Record Slide Show" in the "Slide Show" panel. Use the marks in the 
printed notes to click and start the animation effects and advance to the next 
slide while listening to the narration. 

In PowerPoint 2010 you have an option to save the slide show with the animations and 
narrations as a high-quality Windows media Video (.wmv) file, played back on 
computers even if PowerPoint is not installed. To do that, click "Share" and then under 
'File Types" select "Create a Video." 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Working with Movies in PPT 

You can embed a video or link to a video from your PowerPoint presentation. When you 
embed your video, you don't have to worry about lost files when you deliver your 
presentation because all the files are there. If you want to limit the size of your 
presentation, you can link to a video file on your local drive or to a video file that you 
uploaded to a web site, such as YouTube or hulu.  

Embed a video in your presentation 

With Microsoft PowerPoint 2010, you can now embed a video from a file directly into 
your presentation. And, as you have with earlier versions of PowerPoint, you can also 
embed an animated .gif file from the Clip Art library.  

 Notes   

PowerPoint will support QuickTime (.mov, .mp4) and Adobe Flash (.swf) files when you 
have installed the QuickTime and Adobe Flash players.  

There are some limitations when using Flash in PowerPoint 2010, including the inability 
to use special effects (such as shadows, reflections, glow effects, soft edges, bevels, 
and 3-D rotation), the fade and trim capabilities, and the ability to compress these files 
for easier sharing and distribution.  

PowerPoint 2010 does not support 64-bit versions of QuickTime or Flash.  

 

Embed a video from a file 

1. In Normal view, click the slide in which you want to embed a video.  

2. On the Insert tab, in the Media group, click the arrow under Video, and then 

click Video from file.  

3. In the Insert Video dialog box, locate and click the video that you want to 

embed, and then click Insert. 

TIP   You can also click the Video icon in a content layout to insert a video. 



 

  

Link to a video file from your presentation 

You can link to an external video or movie file from your Microsoft PowerPoint 2010 

presentation. By linking your video, you can reduce the file size of your presentation. 

To add a link to a video from your PowerPoint presentation, do the following: 

1. On the Slides tab in Normal view, click the slide to which you want to add a 

video or animated GIF file.  

2. On the Insert tab, in the Media group, click the arrow under Video.  

3. Click Video from File, locate and click the file that you want to link to.  

4. On the Insert button, click the down arrow, and then click Link to file.  



IMPORTANT   To prevent possible problems with broken links, it is a good idea 

to copy the videos into the same folder as your presentation, and link to them 

there 

 

Link to a video file on a web site 

You can link to a video file on your local drive or to a video file that you uploaded to a 

web site, such as YouTube or hulu.  

IMPORTANT   Please make sure that you obtain the owner's approval before you 

distribute content (that you did not create) that is copyrighted. 

1. On the Slides tab in Normal view, click the slide to which you want to add a 

video.  

2. In your browser, go to the web site that contains the video that you want to link 

to, such as YouTube or hulu.  

3. On the web site, locate the video, and then locate and copy the Embed code.  



4.  Note    Most web sites that contain videos include an embed code, yet the 

locations of embed codes will differ depending on each web site. And, some 

videos do not have an embed code, and therefore you cannot link to those. And, 

to be clear, even though they are called 'embed codes', you are actually linking 

to the video and not embedding it in your presentation. 

 

 

1. In YouTube, the Embed code is located to the right of the video. 

2. Back in PowerPoint, on the Insert tab, in the Media group, click the arrow under 

Video.  

3. Click Video From Web Site.  

4. In the Video From Web Site dialog box, paste the embed code, and then click 

Insert. 

 

 

 

 

 

 

 



 

How to Upload PowerPoint to YouTube 

Microsoft PowerPoint is the de facto standard for slide show and presentation 

creation software. With Microsoft PowerPoint you can create slide shows that react 

as you click, that are optimized for projection or large room display. PowerPoint slide 

shows also represent an easy way of distributing information in a simple slide 

format. If you have created a PowerPoint presentation and want to distribute it to 

someone, without giving them access to edit it, you can use an online site like 

YouTube to host it. Using YouTube to distribute your PowerPoint presentations 

requires you to first export it as a video. Microsoft PowerPoint can easily export to 

video and so no additional software is required. 

 
 

Instructions 

1. Open the Microsoft PowerPoint presentation file that you want to upload to 
YouTube. Make sure that it is completely finished and free of errors. 
 

2. Click "File," then click "Save & Send" to load up the alternative export options. 
 

3. Click "Create a Video" under the "File Types" list, then click "Computer & HD 
Displays." Select the "Web" option from the list, then click "Create Video." 
 

4. Specify a location for your exported video to be saved, then click "Save." 
 

5. Go to the YouTube Video File Upload page (see the "Resources" section of this 
article) and click "Upload video." Locate your exported video from PowerPoint, 
select it and click "Upload" to upload your PowerPoint presentation to YouTube. 

 
 
 

How to upload your video to YouTube 

Once you have created your video, make sure it's smaller than 2GB in size, in an 
acceptable file format, and less than 15 minutes unless you have permission to 
upload videos of unlimited duration.  

http://www.google.com/support/youtube/bin/answer.py?answer=55744


If all of these things are in order, you are now ready to upload! 

To upload your video: 

1. Click the Upload link at the top of any YouTube page. 
2. Click the Upload video button to browse for the video file you'd like to upload to our site. 

Select the file you want to upload and click Open. 
3. As the video file is uploading, enter as much information about your video as possible in 

the relevant fields (including Title, Description, Tags, and Category). You're not required 
to provide specific information, but the more information you include, the easier it is for 
users to find your video! 

4. Click the Save changes button to save the updates you've made to the video file. 

Have more than one video file to upload?  

Not a problem! You can upload up to 10 video files in a single uploading session 
 

 

Here's a list of some well-known formats that YouTube supports: 

 WebM files - Vp8 video codec and Vorbis Audio codecs 
 .MPEG4, 3GPP and MOV files - Typically supporting h264, mpeg4 video codecs, and 

AAC audio codec 
 .AVI - Many cameras output this format - typically the video codec is MJPEG and audio 

is PCM 
 .MPEGPS - Typically supporting MPEG2 video codec and MP2 audio 
 .WMV  - Windows Movie Maker, PowerPoint video 
 .FLV - Adobe-FLV1 video codec, MP3 audio 

 


